Payrix Portal Unavailable

Incident Report for Worldpay for Platforms

Resolved

Monitoring has not indicated any further issues, and the Payrix portal is working as expected
Posted Jun 12, 2025 - 16:59 EDT

Monitoring

Service has been restored on the Payrix Portal. Our teams continue to monitor performance and do not anticipate any additional issues.
Posted Jun 12, 2025 - 16:31 EDT

Investigating

Payrix engineers were alerted to an issue with the Payrix Portal being unavailable. Our engineers are investigating the problem, and updates will be provided as they become available
Posted Jun 12, 2025 - 16:16 EDT
This incident affected: Production - Management Portal.