Payrix Portal May be Slower than Expected

Incident Report for Worldpay for Platforms

Resolved

Monitoring has not indicated any further issues, and the Payrix portal is working as expected
Posted Aug 21, 2025 - 16:26 EDT

Update

The issue has been identified, and we are starting to see the errors and latency come down.

The Payrix team is continuing to monitor.
Posted Aug 21, 2025 - 15:34 EDT

Monitoring

The latency issues look to be caused by a 3rd party vendor.

Payrix teams are going to continue to monitor.
Posted Aug 21, 2025 - 15:24 EDT

Investigating

Users on the Payrix Portal may encounter 500 errors or see longer-than-expected loading times.

Payrix is currently investigating the root cause.
Posted Aug 21, 2025 - 14:33 EDT
This incident affected: United States (Production - API, Production - Management Portal) and Canada (Production - API, Production - Management Portal).