The Federal Reserve has confirmed that all outstanding ACH files have now been successfully processed. Payrix has verified that all funding files from March 2 and March 3 were processed, and no further action is required. Payrix systems are operating normally.
Posted Mar 04, 2026 - 10:03 EST
Monitoring
Payrix is aware of a nationwide ACH issue being reported by the Federal Reserve. Our teams are actively monitoring the situation and validating any potential impact to our systems. At this time, we have not observed any funding impacts. Should the outage begin to affect our operations, funding delays may occur while the Federal Reserve resolves the underlying issue. We are continuing to monitor the situation and will provide additional updates as new information becomes available. More information can be found on the Federal Reserve's status page https://www.frbservices.org/app/status/outage.do?oId=145787
Posted Mar 03, 2026 - 13:18 EST
This incident affected: United States (Platform Notifications).