AWS Data Lake Information Delayed
Incident Report for Payrix
Resolved
This incident has been resolved.
Posted Apr 19, 2023 - 11:14 EDT
Update
AWS engineers have provided the Payrix engineering team with additional parameters to use within the AWS Data Lake environment to fully resolve this issue. The process is underway, and the AWS team believes this should be completed by tomorrow morning no later the 9:00 AM ET. Once all the data is synced, no further impact is expected. Payrix will be monitoring the environment closely and provide further updates if any there are any changes outside of what was presented.
Posted Apr 18, 2023 - 17:40 EDT
Identified
AWS has informed Payrix that this is a broader issue within their environment. Their engineering team is continuing to work on this issue to fully resolve it as soon as possible. AWS engineers have provided Payrix with a workaround for this issue that we are currently reviewing. The next update will be provided within 2 hours.
Posted Apr 18, 2023 - 14:36 EDT
Investigating
Payrix engineers have become aware of an issue impacting the AWS Data Lake. The current impact of this event is that the below Payrix reports that utilize the data lake will not have yesterday's data included.

Transactions Detail Report
Profit & Loss Statement
Balance Detail Report
Disbursement Summary

Payrix engineers continue to work closely with the AWS engineering team to resolve this as quickly as possible. While there is no current estimated time to resolution, Payrix will provide an additional update within 2 hours.
Posted Apr 18, 2023 - 12:24 EDT
This incident affected: AWS Data Lake.