The scheduled maintenance activity planned for June 22, 2025 from 2:00 AM EDT until 3:00 AM EDT has been postponed. The new date and time for the maintenance will be communicated once confirmed.
Posted Jun 22, 2025 - 02:00 EDT
Update
The scheduled maintenance activity planned for June 22, 2025 from 2:00 AM EDT until 3:00 AM EDT has been postponed. The new date and time for the maintenance will be communicated once confirmed.
Thank you for your understanding.
Posted Jun 19, 2025 - 16:48 EDT
Scheduled
Payrix engineering will perform database maintenance to ensure continued reliability and performance improvement. During this time, the Payrix Portal and transaction processing via the Payrix API and Portal will be intermittently unavailable across the hour-long window. Any transactions submitted during the maintenance could fail and should be resubmitted upon completion of the window. API and Portal reads / responses will remain available throughout the window.
Posted Jun 03, 2025 - 10:52 EDT
This scheduled maintenance affected: Production - API and Production - Management Portal.